LOG IN SIGN UP
Documentation

Browser recommendations when using the Fastly web interface

  Last updated June 19, 2017

We support the latest version of the following browsers:

If you aren't using one of these browsers, then some visual styling may not be correct when using the Fastly web interface.

We strongly recommend updating your browser before beginning any debugging of Fastly services and before reporting problems to Fastly Customer Support. You can find the latest, downloadable versions of all major browsers online. The list at Browse Happy may help you.


Back to Top