search close

Compatibility & Requirements

access_time Updated Dec 5, 2022

IMPORTANT: Beginning January 31, 2023, the agent end-of-support policy will take effect. Per this policy, we will support agent versions that are under two years old. On a quarterly cadence, we will deprecate and no longer support agent versions that are older than two years. At the end of January, we will support Agent v4.16.0 and above. If you need help upgrading your agent to a supported version, contact securitysupport@fastly.com.

IMPORTANT: Support for the Python and PHP modules will be moving to self-service in March 2023. At that time, you may continue to use the modules at your own discretion, but we will no longer update and provide technical support for the modules. Until the transition occurs, we will fully support both modules. More information about this transition will be posted at a later date. Reach out to your account manager or securitysupport@fastly.com if you have any questions about this transition.

Processors

Intel

All agent and module versions are compatible with Intel processors.

AMD

All agent and module versions are compatible with AMD processors.

ARM

We support ARM processors on agent v4.27.0 and higher. Dedicated agent packages are available for Ubuntu, Debian, and CentOS.

We do not currently provide ARM agent packages for Red Hat, Alpine, Amazon Linux, or Windows.

You can run the agent on ARM processors with the NGINX C Binary module v1.18.0+ on Ubuntu and Debian. Alternatively, you can run the agent on ARM processors without a module in reverse proxy mode on Ubuntu, Debian, and CentOS.

Linux

The Signal Sciences Agent and Modules are supported on the following Linux distributions:

Distribution Code Name Version
Alpine 3.11
3.12
3.13
3.14
Amazon Linux >2015.09.01
CentOS Enterprise Linux 6 6.x
Enterprise Linux 7 7.x
Enterprise Linux 8 8.x
Enterprise Linux 9 9.x
Debian Wheezy 7.x
Jessie 8.x
Stretch 9.x
Buster 10.x
Bullseye 11.x
Red Hat Enterprise Linux 6 6.x
Enterprise Linux 7 7.x
Enterprise Linux 8 8.x
Enterprise Linux 9 9.x
Ubuntu Precise 12.04 LTS
Trusty 14.04 LTS
Xenial 16.04 LTS
Bionic 18.04 LTS
Focal 20.04 LTS
Jammy 22.04 LTS

Only 64-bit environments are supported. If you need 32-bit support contact us.

Signal Sciences Module

The Signal Sciences Module is a lightweight module that integrates with your web server software or application and is the interface between incoming requests and our agent process. We support NGINX, Apache, and IIS web servers, the HAProxy proxy server, and several application languages (including .NET, Golang, Java, Node.js, Python). Specific details for some of the more commonly deployed platform are listed below:

NGINX Web Servers

The NGINX modules provided by Signal Sciences are built specifically for the NGINX.org distributions of NGINX and may not be compatible with a custom build of NGINX. If switching to an NGINX.org distribution is not an option, reach out to our support team or your Signal Sciences account team for assistance.

The NGINX module is offered in two different variations, depending on the platform and what best meets your needs. We currently support:

C Binary

The NGINX Module is available in a variation built as a C binary, which requires no dependencies. Versions of Nginx-org supported by the C binary are:

  • 1.23.0 - 1.23.1
  • 1.22.0
  • 1.21.0 - 1.21.6
  • 1.20.0 - 1.20.2
  • 1.19.0
  • 1.18.0
  • 1.17.9
  • 1.17.8
  • 1.17.7
  • 1.17.6
  • 1.17.5
  • 1.17.4
  • 1.17.3
  • 1.17.2
  • 1.17.1
  • 1.17.0
  • 1.16.1
  • 1.16.0
  • 1.15.12
  • 1.15.10
  • 1.15.9
  • 1.15.8
  • 1.15.7
  • 1.15.3
  • 1.14.1
  • 1.12.2
  • 1.10.3 (on Ubuntu 16.04 only)

Versions of NGINX Plus supported by the C binary are:

  • 27-1 (1.21.6)
  • 26-1 (1.21.5)
  • 25-1 (1.21.3)
  • 24-1 (1.19.10)
  • 23-1 (1.19.5)
  • 22-1 (1.19.0)
  • 21-1 (1.17.9)
  • 20-1 (1.17.6)
  • 19-1 (1.17.3)
  • 18-1 (1.15.10)
  • 17-1 (1.15.7)

These C binary versions are kept up-to-date with stable releases and on demand for mainline releases.

Lua

Alternatively, a variation of the NGINX Module as Lua is available, which requires NGINX to be built with Lua and for LuaJIT support.

This version is written in Lua and requires your NGINX binary to be compiled with the third party ngx_lua module enabled. We also require the ngx_lua module be linked against the LuaJIT just-in-time byte code library for performance.

NGINX deployments vary from organization to organization, and we support two approaches to this installation:

  • Pre-built binary packages - for all the OS platforms we support we provide three flavors or pre-built NGINX packages that are built with the required ngx_lua module.
  • Source builds - for those organizations building NGINX internally from source, we have published our reference build guidelines that can be used to review and adapt for your own build process.

If you currently use a pre-built binary package of NGINX, either from the operating system’s package collection or from the official NGINX package repositories let us know, and we can provide a suitable replacement package built with our required supporting modules. Contact us for more information.

The Lua variation of the NGINX module is supported on the following versions of NGINX:

Release Versions
1.0 1.0.15
1.1.19 1.1.19
1.2 1.2.7, 1.2.9
1.4 1.4.6
1.6 1.6.0, 1.6.1, 1.6.2
1.7 1.7.2, 1.7.4, 1.7.7, 1.7.8, 1.7.9
1.8 1.8.x
1.9 1.9.x
1.10 1.10.x
1.11 1.11.x
1.12 1.12.x

Apache Web Servers

Our Apache module is distributed in binary form as an Apache shared module and supports Apache version 2.2 and 2.4.

Microsoft Windows Servers

  • IIS 7 or higher, Windows Server 2008R2 (Windows 7) or higher (64-bit)
  • .NET 4.5 or higher

We currently only support 64-bit and 32-bit application pools on Windows 2012 or higher. We only support 64-bit application pools on Windows Server 2008R2.

Additionally, we only support 64-bit OSes. For older or 32-bit versions of Windows, it is possible to deploy the Signal Sciences Agent as a reverse proxy. If you have questions or require assistance with older or 32-bit versions of Windows, reach out to our support team.

HAProxy Servers

HAProxy module

Our HAProxy module is written in Lua and requires your HAProxy binary to be compiled with the lua module enabled.

The HAProxy module requires HAProxy 1.8 or higher.

Note: Although supported, there is a known issue with HAProxy 1.8 that may result in performance issues when the Signal Sciences module is installed. HAProxy has fixed this issue with HAProxy 2.2, but the fix will not be backported to 1.8. It is recommended to upgrade to HAProxy 2.2 or higher if possible, or use an alternate Signal Sciences deployment method (e.g., reverse proxy agent if HAProxy 1.8 must be used).

HAProxy SPOE module

Our HAProxy SPOE module does not require Lua.

The HAProxy SPOE module requires HAProxy 1.8 or higher.

Node.js

0.10 or higher

Java

  • Java 1.8 or newer
  • Spring version 2.x
  • Spring Boot Tomcat Starter 2.x
  • Spring Boot Starter WebFlux 2.x
  • Tomcat 8

PHP

Our PHP module is available both as a tarball and a PEAR package to simplify installation. The minimum version of PHP supported is 5.3.